Title photo
frugal technology, simple living and guerrilla large-appliance repair
Mon, 01 Aug 2011

Windows 7 Service Pack 1 installs begrudgingly on my Debian Squeeze-running laptop

Thanks to readers who responded, Service Pack 1 successfully installed on my Debian-squeeze-running laptop.

Here's a chronicle of what I've done to the machine:

Those who read my previous entry on this topic know that SP1 refused to install on the Windows 7 Home Premium portion of my Lenovo G555's hard drive.

And it probably had something to do with my running Linux (specifically Debian Squeeze) on the same drive.

Nothing I did would make this Service Pack install. I wasn't obsessed with it or anything -- just a failed upgrade every couple weeks. That's about how often I boot into Windows.

After posting about it on this blog, more than a couple of readers suggested I use a live CD with GParted to mark the Windows partition as bootable.

Supposedly Linux doesn't care whether or not it is marked bootable. Nor does Windows, I can tell you. Until Service Pack time.

So this morning I started up Parted Magic 5.10, marked the first (about 100 MB) Windows partition as bootable. Then I booted into Windows and tried the SP1 upgrade again. It didn't work.

So I started the Windows Update repair utility (the exact name of which eludes me at the moment). It made two repairs, not telling me anything at all regarding what they were (in true Windows fashion).

The Service Pack then started installing.

But now the machine is stuck in "Shutting Down" mode. That's what the screen has said for the past 20 minutes).

Windows is supposed to be easier to deal with than Linux? When did that happen? Didn't get the memo on that one.

I'm going to manually power down the laptop now by holding down the power button. We'll see what shape things are in if/when I can boot into either OS (Windows or Debian).

Minutes later: The Windows Update repair thingy didn't kill Grub. I'm booting into Windows 7 right now.

The Service Pack is being configured, according to the message on the screen.

And now I'm logging in.

The window on my desktop says:

Windows 7 Service Pack 1 is now installed

I go straight into Windows Update to see what else I needed, if anything. I have five more updates to install after the Service Pack. Another reboot is required.

I log back in and check Windows Update again:

Windows in up to date: There are no updates available for this computer

Last test: Can I boot into Debian?

Yes, I can.

So to sum up:

  • In dual-boot situations, Windows will run if its first partition isn't marked as bootable. It will update in this configuration, but it won't install Service Packs.
  • Once the first Windows partition is marked bootable (I used the Parted Magic live CD to do to this with Gparted), Service Pack 1 still wouldn't install. I used the Windows Update repair utility, which did a couple of things (I'm not sure what) to the installation. After that, Service Pack 1 installed.
  • The system didn't cleanly shut down after the SP1 install. I had to manually shut down by holding down the power button. After that, however, the Service Pack finished its installation during the next boot into Windows 7.
  • None of this affected the Grub bootloader for Linux, and I booted into Debian Squeeze without incident.